Apache Superset Vulnerability: Insecure Default Configuration Exposes Servers to RCE Attacks

Uncategorized Cyber-Wall.com todayApril 26, 2023 3

Background
share close

The maintainers of the Apache Superset open source data visualization software have released fixes to plug an insecure default configuration that could lead to remote code execution.

The vulnerability, tracked as CVE-2023-27524 (CVSS score: 8.9), impacts versions up to and including 2.0.1 and relates to the use of a default SECRET_KEY that could be abused by attackers to authenticate and access unauthorized resources on internet-exposed installations.

Naveen Sunkavally, the chief architect at Horizon3.ai, described the issue as “a dangerous default configuration in Apache Superset that allows an unauth attacker to gain remote code execution, harvest credentials, and compromise data.”

It’s worth noting that the flaw does not affect Superset instances that have changed the default value for the SECRET_KEY config to a more cryptographically secure random string.

https://googleads.g.doubleclick.net/pagead/ads?client=ca-pub-7983783048239650&output=html&h=90&slotname=2185767680&adk=1884131274&adf=4257282429&pi=t.ma~as.2185767680&w=728&fwrn=4&fwrnh=100&lmt=1682502283&rafmt=12&format=728×90&url=https%3A%2F%2Fthehackernews.com%2F2023%2F04%2Fapache-superset-vulnerability-insecure.html&fwr=0&fwrattr=true&rh=90&rw=728&sfro=1&wgl=1&uach=WyJXaW5kb3dzIiwiMTAuMC4wIiwieDg2IiwiIiwiMTEyLjAuNTYxNS4xMzgiLFtdLGZhbHNlLG51bGwsIjY0IixbWyJDaHJvbWl1bSIsIjExMi4wLjU2MTUuMTM4Il0sWyJHb29nbGUgQ2hyb21lIiwiMTEyLjAuNTYxNS4xMzgiXSxbIk5vdDpBLUJyYW5kIiwiOTkuMC4wLjAiXV0sZmFsc2Vd&dt=1682502676546&bpp=2&bdt=721&idt=77&shv=r20230420&mjsv=m202304190101&ptt=9&saldr=aa&abxe=1&cookie=ID%3Dec0bb3ec793da1c0-22950c4aabdd0061%3AT%3D1682329321%3AS%3DALNI_MZGBYl2GvSw0TnG6iIz-7XuTMgGYw&gpic=UID%3D00000c08cef1ebc9%3AT%3D1682329321%3ART%3D1682502423%3AS%3DALNI_Mbit2y1Nq6XaCzElXNTHVhShGGgcQ&prev_fmts=0x0&nras=1&correlator=6097306594072&frm=20&pv=1&ga_vid=1077476264.1682502677&ga_sid=1682502677&ga_hid=862902097&ga_fc=0&u_tz=-420&u_his=3&u_h=864&u_w=1536&u_ah=824&u_aw=1536&u_cd=24&u_sd=1.25&dmc=8&adx=226&ady=1268&biw=1522&bih=722&scr_x=0&scr_y=0&eid=44759875%2C44759926%2C44759837%2C44789761%2C44769662&oid=2&pvsid=1835702107103289&tmod=443010584&uas=0&nvt=1&ref=https%3A%2F%2Fthehackernews.com%2F&fc=1920&brdim=0%2C0%2C0%2C0%2C1536%2C0%2C1536%2C824%2C1536%2C722&vis=1&rsz=%7C%7CeEbr%7C&abl=CS&pfx=0&fu=128&bc=31&ifi=2&uci=a!2&btvi=1&fsb=1&xpc=xcCW7JWo8F&p=https%3A//thehackernews.com&dtd=84

The cybersecurity firm, which found that the SECRET_KEY is defaulted to the value “\x02\x01thisismyscretkey\x01\x02\\e\\y\\y\\h” at install time, said that 918 out of 1,288 publicly-accessible servers were using the default configuration in October 2021.

An attacker who had knowledge of the secret key could then sign in to these servers as an administrator by forging a session cookie and seize control of the systems.

On January 11, 2022, the project maintainers attempted to rectify the problem by rotating the SECRET_KEY value to “CHANGE_ME_TO_A_COMPLEX_RANDOM_SECRET” in the Python code along with user instructions to override it.

Apache Superset Vulnerability

Horizon3.ai said it further found two additional SECRET_KEY configurations that were assigned the default values “USE_YOUR_OWN_SECURE_RANDOM_KEY” and “thisISaSECRET_1234.”

An expanded search conducted in February 2023 with these four keys unearthed 3,176 instances, out of which 2,124 were using one of the default keys. Some of those affected include large corporations, small companies, government agencies, and universities.

Following responsible disclosure to the Apache security team a second time, a new update (version 2.1) was released on April 5, 2023, to plug the security hole by preventing the server from starting up altogether if it’s configured with the default SECRET_KEY.

“This fix is not foolproof though as it’s still possible to run Superset with a default SECRET_KEY if it’s installed through a docker-compose file or a helm template,” Sunkavally said.

“The docker-compose file contains a new default SECRET_KEY of TEST_NON_DEV_SECRET that we suspect some users will unwittingly run Superset with. Some configurations also set admin/admin as the default credential for the admin user.”

Horizon3.ai has also made available a Python script that can be used to determine if Superset instances are susceptible to the flaw.

“It’s commonly accepted that users don’t read documentation and applications should be designed to force users along a path where they have no choice but to be secure by default,” Sunkavally concluded. “The best approach is to take the choice away from users and require them to take deliberate actions to be purposefully insecure.”

Written by: Cyber-Wall.com

Rate it
Previous post

Post comments (0)

Leave a reply

Your email address will not be published. Required fields are marked *